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Introduction

There are numerous requests on Internet newgroups that go something like this:

"l am new to using programmable logic like FPGAs and CPLDs. How do | start? Is there a
tutorial and some cheapl/free tools | can use to learn more?"

Xilinx has a student edition of their Foundation 2.1 software so anyone can get a low-
cost set of tools for designing with programmable logic. | have written this book to give
you a gentle introduction to using the Foundation 2.1I software. (Other programmable
logic manufacturers have released low-cost or free toolsets for their devices. Someone
else will have to write a book for them.)

This book tries to show you quickly how to use Foundation 2.1 to do the following:

» How to start a project and target it at a particular type of FPGA or CPLD.

= How to describe a logic circuit using VHDL, schematics, or both.

» How to simulate your circuit to test its functions.

= How to synthesize a netlist from your circuit.

= How to fit the netlist into an FPGA or CPLD.

= How to check the device utilization and timing.

= How to generate a bitstream for configuring the FPGA or CPLD.

* How to download the bitstream into the device.

= How to test the programmed device.

I will use combinatorial and sequential logic design examples to illustrate the design
flow. Along the way you will see how to use many of the tools bundled into XILINX
Foundation 2.11. | will not go into a great deal of explanation on the theory of operation
of the example circuits or the internal circuitry of the programmable logic device, but | will
provide references to the appropriate texts and application notes on these subjects. In
short, this is just a tutorial to get you started using the XILINX Foundation tools. After
you go through this book you can move on to more advanced topics. The basic

concepts introduced in each chapter are shown below:

Chapter 1 introduces the Foundation 2.1I software. In this chapter, you will use
Foundation to describe a combinational circuit with VHDL, synthesize it,



simulate it, and then compile a configuration bitstream that you can download
and test with an evaluation board.

Chapter 2 shows you how to design and implement a combinational circuit using the
schematic editor included in the Foundation software.

Chapter 3 discusses how to do hierarchical and mixed-mode designs that include both
schematics and VHDL.

Chapter 4 describes the |/O characteristics of FPGAs and CPLDs and shows you how
to specify them in your designs.

Chapter 5 shows you how to design state machines using VHDL or the state machine
editor included in the Foundation software.

Chapter 6 discusses how to perform timing analysis of your combinational and
sequential logic designs.

Chapter 7 illustrates how to use the internal RAMs in a XILINX FPGA and how to
interface an FPGA or CPLD to an external RAM chip.

Chapter 8 describes a simple microcontroller and shows how to implement it in an
FPGA and a CPLD.

In addition to these chapters, there are two appendices in this text:

Appendix A1 steps you through the installation of the Foundation software, its service
pack updates, and its FlexLM license.

Appendix A2 shows you how to configure and set-up your XS40 or XS95 Board so it
can be used to run the design examples.

You should read both appendices before beginning on Chapter 1. That ensures you
have the software and hardware installed correctly and reduces the chance of
encountering a problem while doing the examples.

All the project files for each design example are provided on the CDROM. You should
be able to re-create each design just from following the text, but you can use the project
files in case you have problems or are in a hurry. Of equal importance, these working
examples serve as a starting point for your own designs and explorations.

After you complete this book will you be an expert in using programmable logic and the
Foundation 2.11 tools? The answer is a definite NO. This text is just a starting point.
After you complete this text you will be able to:

» Understand the basic structure of the XILINX XC9500 CPLDs and XC4000 FPGAs
and be able to further your understanding by reading their respective datasheets.

= Understand the basic functions of the Foundation 2.11 software tools.

» Use Foundation to create, synthesize, simulate, and compile logic circuits for CPLDs
and FPGAs.



= Analyze the performance of your circuit with respect to a given XILINX CPLD or
FPGA.

= Download and test your circuit on an FPGA or CPLD evaluation board.



VHDL-Based Design

n this chapter you will learn how to:

Create a project with Foundation 2.1i.

Enter VHDL code describing your logic circuit and check-and-correct any syntax
errors.

Pass the VHDL code to a synthesizer to generate a netlist for a particular FPGA or
CPLD.

Simulate the operations of the netlist to check the logical functions of your circuit.
Transform the netlist into a configuration bitstream using the implementation tools.
Download the bitstream into an FPGA or CPLD evaluation board.

Test your circuit with the FPGA or CPLD evaluation board.

Overall Design Flow

Creating a logic circuit for a CPLD or FPGA usually consists of the following steps

(depicted in Figure 1)):

1.

2.

3.

You enter a description of your logic circuit using a hardware description language
(HDL) such as VHDL.

You use a logic synthesizer program to transform the HDL into a netlist. The netlist
is just a description of the various logic gates in your design and how they are
interconnected.

You test the functions of your circuit by loading the netlist into a simulator, applying
input patterns (known as test vectors), and observing the simulated outputs.



Look at the datasheet
and XAPP097 for more
details about the
XC4000XL FPGAs.
The XC9500 datasheet
and XAPP073 have
more information about
the internal structure of
CPLDs.

See page 372 of Digital
Design Principles and
Practices by John
Wakerly for a detailed
explanation of LED
decoders.

4. You use implementation tools to map the logic gates and interconnections into the
FPGA. The FPGA consists of an array of slices which can be further decomposed
into configurable logic blocks (CLBs) that perform logic operations using a set of
look-up tables (LUTs). The CLBs are interwoven with various local and global
routing resources. The fitter places gates from your netlist in various CLBs in the
slices and opens or closes switches in the routing resources to wire the gates
together. (A similar process occurs when you use a CPLD except the slices are
called configurable function blocks (CFBs), the CLBs are called macrocells, and the
routing resources are called routing matrices.)

5. Once the implementation is complete, the state of the routing switches and CLBs (or
macrocells) is extracted to create a bitstream where the ones and zeroes correspond
to open or closed switches.

6. The bitstream is downloaded into a physical FPGA or CPLD chip (usually embedded
in some larger system). The electronic switches in the device open or close in
response to the binary bits in the bitstream. Upon completion of the downloading,
the FPGA or CPLD will perform the operations specified by your HDL code.

That's really all there is to it. XILINX Foundation 2.1i provides the HDL editor, logic
synthesizer, simulator, implementation tools, and bitstream generator software. The
GXSLOAD utility from XESS will download the bitstream into an XS40 FPGA Board or
an XS95 CPLD Board.

In the rest of this chapter we will follow the design flow of [Figure 1] while designing a
simple LED decoder circuit. The decoder will take a four-bit input that represents a
hexadecimal number (0000...1111 - 0x0...0xF) and will output seven signals that drive
a seven-segment LED display so it shows the corresponding hexadecimal digit (O, 1,
2,3,4,5,6,7,8,9,A, b,C,d, E, F).



VHDL Source Code

entity leddcd is
port(
d: in std_logic_vector(3 downto 0);

)

end;

architecture leddcd_arch of leddcd is
begin
s <="1110111" when d="0000" else
"0010010" when d="0001" else
"1101101";
end leddcd_arch;

s: out std_logic_vector(6 downto 0);
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Figure 1: Steps in creating and testing an FPGA or CPLD-based design.




Starting a Project

Praject

To begin the LED decoder project, double-click the 818888 start-up icon for Foundation
2.1i which will bring up the Project Manager window.
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In the Getting Started dialog window, click on the Create a New Project radio button and
then click on the OK button.
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The New Project window appears where you setup the project. First, you must specify
the directory where the project design files will be stored. The Directory field is initialized
with the default directory within the Foundation directory tree. It is OK to place your
projects there, but in this book | will place all the examples in a separate directory called
Prag21i. To do the same, begin by clicking on the Browse... button.
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Scroll down in the list of directories in the Browse for Folder window and highlight the
Prag21i folder. Then click on OK.
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The path to the selected project folder will now appear in the Directory field. Next you
must name your project. | placed the string dsgn1_1 in the Name field to indicate this is the
first design of Chapter 1 of this book, but you can use any name you like.
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Next, choose to create an HDL-based design rather than a schematic-based design by
clicking on the HDL radio button. Once you do this, the fields for selecting the
programmable device family will disappear from the bottom of the window. That’'s OK.
We will select the target device for the LED decoder circuit when we run the synthesizer
later on.
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This completes the initial setup for the LED decoder project, so click on the OK button.
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Now the Project Manager window appears as shown below. You can execute
operations using the menu items and buttons in the menu and toolbars across the top of
the window. The results of these commands are reported in the Command History
pane at the bottom of the window. Your current point within the process of creating your
design is indicated within the Project Flow pane. And the various files that make up
each iteration of your design are listed in the Project Hierarchy and Version pane.
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Creating the VHDL Source Code

The first step is to enter your VHDL code for the LED decoder into a file. Start the HDL
editor by clicking on the left-most icon of the Design Entry block in the Project Flow pane.
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This brings up an HDL Editor window and a dialog box in which you can select how you
want to enter your new code.
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If you are an experienced HDL coder, you will probably select the Create Empty option to
start with an empty editor window where you can type-in your source directly. In this
example, we will select the Use HDL Design Wizard option which will lead us through the
creation of a code skeleton that we can modify to describe the LED decoder circuit.
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After clicking OK in the previous window, the Design Wizard window appears. Click
Next> to move on.
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Type-in the name of the file in which you want to store the VHDL code. This does not
have to be the same name as the entire project. | used leddcd for this example. After
specifying the file name, click on Next>.
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The window for specifying the inputs and outputs of the LED decoder circuit now
appears. Begin by clicking on the New button.
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Next, type the name of the input port to the LED decoder. (I have named it d in this
example.) The type of the port is selected by clicking one of the radio buttons in the
Direction portion of the window. The Input button is selected by default so no action is
needed in this case.
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As mentioned previously, the LED decoder takes a four-bit input so we need to set the
width of the d input bus. Click three times on the upper-left button of the Bus field to set
the d input to four bits as shown below. The d input bus will appear on the left-hand side
of the design block and in the list of 1/0 ports.

Design Wizard - Ports |

To create a new port click Mew.

Lz To change attributes of a port, zelect it on the lizk. Then
wou can change its name, range and direction; to set ather
attributes chck Advanced.

To delete a port zelect it on the lizt and click Delete.

14 M ame: Bus
[drz01 =30 1
Direction
i |nput = Output

" Bidirectional

P e | Delete | Advanced... |

¢ Back I Finizh I Cancel |




Now that the description of the input port is completed, click on the New button to start
describing the output port. Then click on the Output button to set the direction of the port.
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Type-in the name of the output port (s in this case) and then click on the upper-left Bus
button six times. This sets the number of outputs to the seven required to drive a seven-
segment LED.
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Now that the input and output ports have been described, click on the Finish button.
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A VHDL code skeleton for the LED decoder circuit now appears in the HDL Editor
window. The skeleton is composed of the following parts:

Lines 1-2: The standard IEEE library is linked in so our VHDL code can make use of
the various functions and type declarations it contains.

Lines 4-9: The ports through which the circuit inputs and outputs signals are defined in
the entity section.

Lines 11-14: The statements that describe the operations of the LED decoder circuit
are placed in the architecture section. These statements will replace line 13.
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2 use IEEE.std_logic_1164.all;

3

4 entity leddcd is

5 port

] d: in STD_LOGIC_UECTOR (2 downto @);

Fi s: out STD_LOGIC_WECTOR (6 downto @)

8 ) H

9 end leddcd;

18

11 architecture leddcd arch of leddcd is

12 begin

13 -— <<enter your statements herel>

14 end leddcd_arch;

15

16

17

18

19

20

21

22

23
Al 2
[+ | 2
For Help, press F1 | Lnt1.Colil wHDL | | | | Yy




The skeleton code on line 13 is replaced with the VHDL code on lines 13-29 shown in
the window below. This code specifies the particular seven-bit value that will appear on
the s outputs for each possible four-bit value that is driven into the d inputs. A high level
on an output will illuminate the LED segment to which it is attached. (See [Figure J for
the correspondence between the s outputs and the individual segments that make up
the LED digit.)
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After entering the VHDL code, it's a good idea to see if there are any obvious errors. Do

this by selecting the Synthesis=>Check Syntax menu item.
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The syntax checker will parse the VHDL code and will return an error message in the
bottom pane of the HDL Editor window informing you that there is an error on line 30.
Click on the OK button to remove the pop-up error window.

Line 30 was generated by the HDL Design Wizard, so it is unlikely that it has a syntax

error. The actual error is at the end of line 29 where | have left off the terminating
semicolon.
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Once the semicolon is appended to line 29, the syntax checker is run again and the
VHDL is judged to be free of syntax errors. Click on the OK button to remove the pop-up

window.

= leddcd. vhd - HDL Editor
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Project

Toolz Help
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9 end leddcd;
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11 architecture leddcd arch of leddcd is

12 begin

13 with d select

14 & <= 11180111 when 0880,

15 “@e18816*" when @881,

16 “1811181" when *“@ai1a"”,

18 “g111a14a

19 "“1181811

a8 s1e1111 & Check Successtul.
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23 1111811

24 “1111114

25 “|1e1111" when 1811,

26 “1188181" when 1188,

27 “ae11111" when 1161,

28 “1181181" when 1118,

29 “1181188" when others;

38 end leddcd_arch; ||
i o
Checking...
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[+] |

| Ln29,Col 3 [WHOL |
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Now that the code has passed the syntax checker, save it in the leddcd.vhd file using the

File=>Save menu item. You can then exit from the editor.
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We have a VHDL file that describes the LED decoder, but it isn’t a part of our poject yet.
We must add the file to our project using the Project->Add Source files... menu item.

dzgnl_1 - dezign not implemented - Project Manager

Pecm o Update: COPRAGZIRDSGMNT _1edded.vhd (0, 0
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The leddcd.vhd file will be seen in the Add Document window that appears. Highlight this
file and then click on Open to add the file to the project.

AddDocument ———HE
Lok in: |ﬁ dzgnl_1 j ﬁl
I dzagni_1
b
WProj

File name: |Ieu:|u:|u:u:|.vhu:| Open

Files of type:  [HDL (*VHD * VER . VE ") -] Cancel

il

Help




The left-hand pane of the Project Manager window now shows the leddcd.vhd file that we
added. The green checkmark by the file name indicates that the VHDL in the file is
syntactically correct. The green checkmark in the Design Entry box in the right-hand pane
denotes that this phase of the design flow is completed.

‘» dzgnl_1 - design not implemented - Project Manager
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Synthesizing a Netlist

Now that we have the VHDL description of the LED decoder completed, we can run the
synthesizer on it to produce a netlist for the circuit. You can initiate this phase by
clicking on the Synthesis box in the Design Flow pane of the Project Manager window.

‘» dzgnl_1 - design not implemented - Project Manager
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We set the parameters that control the synthesis process in the
Synthesis/Implementation settings window that appears. Of most importance is to
select the target device for the LED decoder circuit.

Synthesiz/Implementation zettings |

Top lewel: leddcd
Wersion name: I'-.fer'l (] |
Synthesis Settings: SET I LCarncel |

Help |

Target Device
Famiy: [>C40006<L -]

Device: |4002<LPCa4 =] Speed: [woa -

[ Edit SynthesisAmplementation constraints

[ ‘iew E stimated Performance after Optimization

™ sute Bun [ mplementation bools

Phwszical Implementation zettings

Revizion name: Irev'l Wptions |

Contral Files: SET




We plan to test this design on an XS40-005XL Board that contains a XILINX XC4005XL
FPGA chip in an 84-pin PLCC package. The XC4000XL FPGA family is already set in
the Family field of the Target Device area of the window. So we only need to select the
particular device in the family (XC4005XLPC84 in this case) from the drop-down list of
the Device field.

Synthesiz/Implementation zettings

Toplevel |leddcd R
Wersion name; I'-.fer'l k. |
Sunthesiz Sethings: SET I LCancel |

Target Device
Famiy: [>C40006<L -]

Device: | 4005:<LPCS4 =] Speed: [woa -

| 4002410100 -
I™ i Sy TSR I i
: 4005=LPO100 s
[ WiewE 4005140100 - fr Ophirmization

™ sute Bun [ mplementation bools

Phwszical Implementation zettings

Revizion name: Irev'l Wptions |

Contral Files: SET




We can also specify the speed grade of the device using the Speed field. The device in
the XS40 Board is usually the slowest model, so select the —3 speed grade as shown
below.

Synthesiz/Implementation zettings

Toplevel |leddcd R
Wersion name; I'-.fer'l k. |
Sunthesiz Sethings: SET I LCancel |

Help |

Target Device
Famiy: [>C40006<L -]

Device: I4I:||]5><:LF'E84 j Speed:

[ Edit SynthesisAmplementation constraints

[ “iew E stimated Performance after O ptiriz g

™ sute Bun [ mplementation bools

Phwszical Implementation zettings

Revizion name: Irev'l Wptions |

Contral Files: SET

There are many other synthesis options we could adjust by clicking on the SET button
and selecting various options in the dialog windows that would appear. There is no need
to do this for this simple example, but we will explore these options in more detail in
following chapters.



Click on the Run button to start the synthesizer.

Synthezizf/Implementation zettings |
Top level: IIE::I::I::::I j Bun
Wersion name: Iveﬂ (]
Synthesis Settings: SET I LCancel |

Help |

Target Device
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Contral Files: SET

A window with a progress bar will appear and show the various phases of the synthesis
procedure. For this simple combinational circuit, the synthesis is completed in less than
ten seconds on a fast PC.

Create Yersion

t apping combinational logic in design 'Averl-Optimized' ... |




The synthesizer shouldn’t encounter any problems generating the netlist for the LED
decoder circuit. Upon successful completion of the synthesis, you will see a green
checkmark in the Synthesis box of the Design Flow pane in the Project Manager
window. There are also two libraries that have been added to the Project Hierarchy
pane: xc4000x and simprims. The xc4000x library contains circuit elements that we can add
to logic circuits that are targeted to XC4000 FPGAs. The simprims library contains
simulation primitives that are used when the Foundation simulator program is simulating
a logic circuit targeted at any XILINX FPGA or CPLD. Right now we don’t have to be
concerned with what’s in these libraries.
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Running a Simulation

Now that we have a netlist, we can use the simulator in Foundation to check the
operation of the LED decoder. Click on the Simulation box in the Design Flow pane to
activate the functional simulator.

‘»dzgnl_1 - verl [400%<LPC84-3] - Project Manager

File Document iew Project  Svnthesziz  Implementation Tools Help

D] 8] Oln| olv| Blg| B B[] M

File=s * “ersions Flowy . Cortentz  Reports

B3 dsgnl_1 =
R edded vhi varl [

= dsgni_1
= simprims "
5 wc4000x @ -

DESIGM ENTRY g

= » B » ﬂ
YHT : SIMULRTI
3 N:SIS L4 Functional Simulation

T
e e @ 1
IMPLEMENTATION ¥ YERIFICATION
A 4
25 =
PROGRAMMING =
Dpm . Modifying design to comply with target technolooy rules . E

Dpm : Done

Fecm o Implementation werl Completed Successiully.

Dpm  : Expaortver!-Optimized to ciprag21idsgnt _1dpm_net ..
Fecm  Reading Synopsysixiling project

Conzaole  HDL Errors © HDL Warnings © HOL Meszages 14 ﬂ

Ready




The Logic Simulator window that appears contains a single Waveform Viewer 0
subwindow for viewing simulated waveforms of signals in the LED decoder circuit.

= Logic Simulator - Xilink Foundation F2.1i [dzgnl_1]
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Now all we have to do is find a way to inject signals into the inputs of the LED decoder
netlist and then observe the response of the outputs. We start by selecting the
Signal->Add Signals... menu item.

o Logic Simulator - Xilink Foundation F2_1i [dsgnl_1]
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The Component Selection for Waveform Viewer window appears with three panes.
For our simple LED decoder, we are only interested in the left-hand Signals Selection
pane. All the input and output ports for the LED decoder circuit are listed in this pane
along with all the internal signals that connect the gates in the synthesized netlist.
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For this example we are only concerned with the inputs and outputs of the LED decoder.
Click on the top entry in the Signals Selection pane to highlight the set of four inputs to
the LED decoder (DO, D1, D2, and D3). Then click on the Add button.
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At this point a red checkmark should appear next to the input ports. This indicates that
the four inputs to the LED decoder have been added to the Waveform Viewer 0

window.
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Repeat the previous operation with the seven LED decoder outputs (S0, S1, S2, S3, $4,
85, and S6). Then click on the Close button to remove the Component Selection
window.
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Now you will see the input and output ports have been added to the Waveform Viewer
window. The four input ports and seven output ports are grouped into buses as
indicated by the B in the left-most column next to their signal names. Therefore, the
logic levels on the four inputs and seven outputs will be grouped and displayed as
hexadecimal values in the logic waveform pane of the Waveform Viewer window.
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For this example it is more convenient to flatten the buses so we can observe the logic
level on each individual input and output port. To do this, right-click on the output bus
and select the Bus—>Flatten menu item in the cascading pop-up menues.
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The individual signals in the output bus are now displayed in the Waveform Viewer
window.
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Next we repeat the bus flattening operation for the input bus. After doing this, we can
see that the bus indicator in the left-most column of the Waveform Viewer window has
been replaced with an i or o depending upon whether the flattened signal is an input or
output, respectively.
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Now that we have all the inputs and outputs displayed in the proper format, we need a
way to stimulate the input ports with binary logic levels so we can observe the response
on the output ports. Select the Signal->Add Stimulators... menu item to begin adding
stimulators to the input ports.
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Now the Stimulator Selection window appears and it has all the buttons and controls
you would ever want to see. But we will only use a few for this example. In the middle
of the window is a binary counter labeled Bc. This counter will increment once for each
time step that the simulator executes during the simulation of the LED decoder. If we
attach the four LED decoder inputs to the lower four bits of this counter, then we can
force all possible input combinations into the decoder circuit over a span of sixteen
simulation cycles.

To begin attaching inputs to the binary counter bits, highlight the least-significant input
port DO.
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Once the DO input port is highlighted, click on the least-significant bit of the binary
counter.
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Now we see that B0 has appeared in the column to the right of the D0 signal name,
indicating that the least-significant input to the LED decoder has been connected to the
least-significant bit of the stimulation counter.
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We can repeat this operation to connect the succeeding three inputs of the LED decoder
to the next three bits of the counter. Then click the Close button.
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Now we are finally ready to test the LED decoder. To run the simulation, click on the
Simulation Step button a few times. The right-hand pane of the Waveform Viewer window
will display the binary counter values forced into the inputs and the resulting logic levels
on the outputs of the LED decoder. The simulation covers a time interval of 50 ns.
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The waveforms may be a bit squeezed to view easily, so you can click the Zoom In button
to expand the time scale. Now we can check the output levels for each input
combination to see if they match the input-output pairs specified in the VHDL code. For
example, when all the inputs are at logic level 0, then all the outputs are at a high logic
level except for S3. This agrees with the behavior specified on line 14 of the leddcd.vhd

file. You can check the response to the remaining fifteen input combinations in a similar
fashion.
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We can exit the simulator now that we have verified the operation of the LED decoder,
but it is wise to save the state of the simulator in case we have to come back and do
more tests later. That way we don’t have to go through all the effort of adding the input
and output signals and attaching stimulators again. Begin this task by selecting the
File->Save Simulation State... menu item.

o Logic Simulator - Xilink Foundation F2_1i [dsgnl_1]
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In the Save Simulation window that appears, type leddcd.des into the File name field and
click on OK. The current state of the simulator will be saved into this file in the project
folder. You can restore the simulator to this saved state by clicking File=>Load simulation
State... in the Logic Simulator window and selecting the leddcd.des file.
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Cancel |
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Finally we can select File->Exit to terminate this simulation session.
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Implementing the Design

Now that the simulation has given us some confidence that our circuit is performing as
an LED decoder, we want to transform the netlist into a bitstream that we can run on a
real XC4005XL FPGA in an XS40 evaluation board. The FPGA has some of its pins
connected to the parallel port of the PC attached to the XS40 board. We can use the PC
to drive logic levels through the parallel port and onto the pins of the FPGA where they
will serve as inputs to the LED decoder in the FPGA. The FPGA also has seven pins
connected to a seven-segment LED digit. The outputs from the LED decoder should be
connected to these pins so we can easily see if the circuit operates correctly. We will
create a user-constraints file that will tell the Foundation implementation tools which LED
decoder inputs or output should be assigned to a particular physical pin of the FPGA.

D

S6
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XC4005XL J

FPGA S92 ' S3 'S ’

L _ 2
SO

Parallel Port Connector
O000000000O0D0

p

060605006008 0060

Figure 2: Connection of the parallel port and LED digit to the pins of the FPGA on
the X840 Board.



To begin creating the user constraints, select the Project->Add Source File(s)... menu item in

the Project Manager window.
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Foundation 2.1i automatically created a user-constraints file called dsgn1_1.ucf when we
started this project. Select this file in the Add Document window and click on Open.

Add Document K |
Look in: I {3l dsanl_1 j ﬂl
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Help




The dsgn1_1.ucf user-constraints file is now added to the project hierarchy. We will place
our pin assignments for the LED decoder in this file. Right-click on the dsgn1_1.ucf label
in the Project Hierarchy pane and select Edit in the pop-up menu.
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The design1_1.ucf file contents now appear in the Report Browser window. Foundation
placed a large amount of information about writing constraints in the file when it was
created. You can use Edit->Select All and Edit->Delete to remove all these comments from
the file, or you can just add your own constraints to the file.

E! dzgnl_1_ucf - Report Browser _ O] x|
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#

# The "#"' symbol is a comment character. To use this sample file, find the
# specification necessary, remove the comment character [#] from the beginning
# of the line, and modify the line [if necessary] to fit your design.

i

# TIMING SPECIFICATIONS

#

# Timing specifications can be applied to the entire device [global] or to

# specific groups in your design [called "time groups']. The time groups are
# declared in two basic ways.

#

# Method 1: Based on a net name. where ‘'my_net' is a net that touches all the

# logic to be grouped in to 'logic_qrp'. Example:

#NET my_net TNM_NET = logic_grp:

#

# Method 2: Group using the key word 'TIMEGRP' and declare using the names of

i logic in your design. Example:

#TIMEGRP group_name = FFS ["U1/™7; =
[+l | _"H

Ready Ln 1, Cal1




The window below shows the pin assignment constraints used when the LED decoder
circuit is targeted to an XS40 Board. The net keyword is followed by the name of one of
the inputs or outputs of the circuit. The Foundation synthesizer places <> around the
index of each element in an input or output bus in the netlist, so signal d0 (for example)
must be referred to as d<0> in the user constraints file. The signal name is followed by
a location constraint indicated by the loc keyword followed by the particular pin the
signal is assigned to. For example, input signal d0 is assigned to pin 44 on the 84-pin
PLCC package of the XC4005XL FPGA on the XS40 Board.

E! dzgnl_1_ucf - Report Browser _ O] x|
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net d<0> loc=p44;
net d<{1> loc=p45;
net d<2> loc=p46;
net d<3> loc=p47;
net s<0> loc=p25;
net 5<{1> loc=p26;
net s<{2> loc=p24;
net 53> loc=p20;
net s<4> loc=p23;
net 5<5> loc=p18;
net s<6> loc=p19t

Fieady | Ln11.Cal17 |OVR | | &




After entering all the constraints, click on File->Save and File->Exit to save the new pin
assignment constraints and close the file.
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Now we can start the implementation tools by clicking on the Implementation block in the

Design Flow pane.
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We are again presented with the Synthesis/Implementation setting window just as we
were when we activated the synthesizer in a previous phase of the design flow. But now
we can only set the options and control files that affect the implementation tools — all the
synthesis settings and the target device selector are locked. This makes sense since
the synthesizer generated a netlist based upon the characteristics of the XC4000 FPGA,
so we cannot decide to implement that netlist on a different type of programmable device
which may not have the same features.

We need to inform the implementation tools about the user constraints file with the pin
assignments for the LED decoder. Click on the SET button in the Physical Implementation
settings area to do this.
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The Settings window lets us specify several types of control files. Guide files are used if
we want the implementation tools to use what they learned in a previous implementation
of this circuit to guide the current implementation process. Similarly, floorplanning files
are created by the designer to give the implementation tools hints about where they
should place the netlist components and wires within the FPGA or CPLD programmable
arrays. Guide and floorplanning files can significantly reduce the time required to
complete the implementation phase. We haven’t run the implementation tools on the
LED decoder yet, and we haven'’t created a floorplan for the circuit so neither of these
options is of interest to us.

Settings |
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But we do have a user constraints file, so click on the Use Constraints file from: field and
select Custom.

Settings |
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The Custom window will display the dsgn1_1.ucf file by default, so all we need to do is
click on OK to enable the use of this control file.
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Now click OK to finalize the settings for the implementation tools.
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Then click on Run to start the implementation tools.
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The Flow Engine window appears that depicts the progress through the five phases of
the FPGA implementation process. Running appears below the currently active phase
while Completed appears for each successfully completed step. Status and error
messages generated during each implementation step scroll through the lower section of
the window. The purpose of each phase is as follows:

Translate: The synthesized netlist format and the user constraints are converted into an
internal database format.

Map: The logic gates in the netlist are grouped to take advantage of the resources in the
FPGA’s CLBs.

Place&Route: The mapped logic gates are placed in specific locations within the
FPGA'’s array of CLBs and the connections between the gates are routed
through the FPGA’s wiring resources.

Timing (Sim): The propagation delays through the CLBs and routing are computed and
stored for use during a timing simulation. (This phase is optional and can be
turned off if you don’t want to do timing simulations.)

Configure: The bitstream that will configure an FPGA with the placed-and-routed circuit
is generated.
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Once all five phases of the implementation process have completed, click on OK in the
status pop-up window.

Project Manager

Flow Engine werl -»rew] Completed Successiully.

A successful implementation is indicated by the green checkmark in the Implementation
box in the Design Flow pane. We can check how much of the FPGA is used by the
LED decoder circuit by selecting the Implementation>View Report Files... menu item or
clicking on the report browser toolbar button as shown below.
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The Report Browser window lists the reports generated by each phase of the
implementation process. We can double-click the Place & Route Report icon to get a view
of the statistics on the usage of FPGA resources.

+ Report Browszer - dsgnl_1[verl->revl]

FPad Report  Asunchronous
Delay Report

Tranzlation  Map Beport
Report

Post Layout  Bitgen Repaort
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Scrolling downward through the place-and-route report brings us to the device utilization
summary. The LED decoder has four inputs and seven outputs, so it uses eleven of the
61 input/output blocks (IOBs) of the XC4005XL FPGA. The design is completely
combinational so its uses none of the FPGA'’s flip-flops and latches. It does use four of
the 392 CLBs in the FPGA. Each CLB contains two four-input lookup tables (LUTs) and
one three-input LUT that perform all the combinational logic duties. The LED decoder
requires seven LUTs to generate its seven outputs, and these seven LUTs are packed
into four CLBs. Overall, we see the LED decoder circuit doesn’t use much of the FPGA
at all.
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We should also check to see if our pin assignment constraints were obeyed. Double-
click the Pad Report icon to inspect the actual pin assignments.
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The input and output names are listed in the pad report file along with the pin number to
which they were assigned during the implementation phase. We can see that the actual
pin assignments match the assignments we placed in the dsgn1_1.ucf user constraints file.
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Downloading and Testing

We have successfully synthesized, simulated, and implemented the LED decoder, so
now we can test it in an actual FPGA. First we should locate the actual LED decoder
bitstream. It can be found in the C:\Prag21\dsgn1_1\xproj\ver1\rev1 folder in the dsgn1_1.bit file.
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Now apply power to the XS40 Board, connect it to the parallel port of your PC, and
double-click the GXSLOAD icon to start the process of loading the LED decoder bitstream

into the XC4005XL FPGA.



Then just drag-and-drop the dsgn1_1.bit file from the rev1 window into the gxsload
window.

= revl
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Fecent Files:
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Once the bitstream file is dropped in the gxsload window, a progress bar will appear to
show the percentage of the bitstream transmitted to the FPGA. The download should
take less than ten seconds, after which a pop-up window will appear to indicate the
XS40 FPGA Board is programmed. Click on OK to remove the pop-up window.

X gxsload =] x|
Drop BIT, 5WF, HEX, and .EX0 Exit |

filez here to download ta the
#5 or %5Y Board.

M G<SLOAD h

@ The *540 Board iz programmed!!

Reload [~ EEFROM Part ||_|:~'|'-| vI




Now we need to drive the inputs of the LED decoder and observe its response on the
LED digit of the XS40 Board. Double-click the GXSPORT icon to start up the utility that
can drive the FPGA inputs through the PC parallel port.

The gxsport window has eight buttons that correspond to the eight parallel port data
pins. The current level on each data pin is reflected in the binary digit displayed within
each button. Clicking a data button toggles the level, but the new output is not driven
onto the parallel port pin until the Strobe button is pressed. We can drive test vectors
into the LED decoder circuit by pressing buttons D0, D1, D2, and D3 to set the desired
pattern and then clicking Strobe.

X gxsport M =]

o o o] o [ _es |
oy DE D5 D4 D3I D2 D1 DO

Strabe | T Count Part I LPTH *I

But there is a faster way than typing in all sixteen input vectors. Just check the Count box
to make the eight-bit value represented by D7...D0 increment every time Strobe is
pressed.

X gxsport M=l E3
i e
oY DE D5 D4 D3 D2 D1 DO

Strobe | I ;nunt Part ILF'T'I *I

Then just click Strobe sixteen times. You should see the LED display the next
hexadecimal digit after each click.

(Xguspot  MEE|
of of of of of of of of e |
DF DeE D& D4 D3 DZ D1 DO
Sibe] Mocomt  FoflFTT ]




Retargeting the Circuit at an XC9500 CPLD

At this point we have synthesized, simulated, implemented, downloaded, and tested the
LED decoder on an XC4005XL FPGA. Now we will retarget the LED decoder at an
XC95108 CPLD device. We will create a new version of the project to hold the modified
design. To start, select the Project->Create Version... menu item.

‘»dzgnl_1 - verl [400%<LPC84-3] - Project Manager

File  Document  Miew | Project Senthesis  |mplementation Tools  Help

0 |E,| ] ﬂ| i Add Source File[z]... @ k‘@
Files * “ersions Create Yersion... k =
B 1 dsgni_1 Delete Yerzion ]
£ dsgn1_1.u Create Revision... N05¥L-3-PCE4) I
S ELEDLRIE Copy Revision...
= dsgni_1 Delete Revizion
= simprims I S ili—
Ear |\mplementalion Lata
i xcd 000k s TRY o
A 4
= » B » @
SYNTHESIS SIMULATION
A 4
o H | B K
IMPLEMENTATION YERIFICATION
A 4
»
PROGRAMMING =
Hig . Flowe Enaine: wverl-=revl (Mapped Ok) E
Hig . Flowe Endine: verl-=rev (Routed O
Hig . Flowe Endine: werl-=revl (Timed Ok)
Hig : Flowe Enaine: verl-=revd {Implemented Ok
Hig . Flowe Endine werl-=revl Completed Successiully,
Conzaole  HDL Errors © HDL Warnings © HOL Meszages 14 ﬂ_

Creates a new version of the design data




Note that the Version name field has automatically been set to ver2 In the Create Version
window that appears. Set the fields in the Target Device area to the values needed for the
XS95 Board as shown below.

Create Yersion

Tap level I leddzd j

Wersion name; I'-.-'erE

Wi
L E3

Synthesis Settings: SET I LCarncel

d

Help

Target Device
Famiy: |*C9500 -]

Device: [35105PCa4 =] Speedt: [N -]

[ Edit SynthesisAmplementation constraints

[ ‘iew E stimated Performance after Optimization

[ Auta Fun Implementation bools

Phwszical Implementation zettings

Revizion name: Irev'l Wptions |

Contral Files: SET

Next, click on the Run button to activate the synthesizer. The synthesizer will create a
new netlist the takes into account the specific features of the XC9500 CPLD
architecture.

Create Yersion |
Toplevel |leddcd -] | Bun
Wersion name; I'-.-'erE k.
Synthesis Settings: SET I LCarncel |

Help |

Target Device
Famiy: |*C9500 -]

Device: [35105PCa4 =] Speedt: [N -]

[ Edit SynthesisAmplementation constraints

[ ‘iew E stimated Performance after Optimization

[ Auta Fun Implementation bools

Phwszical Implementation zettings

Revizion name: Irev'l Wptions |

Contral Files: SET




After the netlist synthesis is complete, the Project Manager window shows a green
checkmark in the Synthesis block of the Design Flow pane. The version label in the
Design Flow pane has also been changed to ver2. We can view more details about the
different versions of the LED decoder project by clicking on the Versions tab in the Project
Hierarchy pane. We see that ver1 is targeted to an XC4005XL FPGA and has been
successfully synthesized (both functional and optimized netlists are present) and
implemented. The ver2 version, however, is targeted at an XC95108 CPLD and has only
been synthesized to this point. No implementation phase has been performed yet.
(That accounts for the yellow question mark in the Implementation block of the Design
Flow pane.) We can activate a version by clicking on its name in the Versions tab. The
ver2 version is currently active, so we will leave it that way.

‘» dzgnl_1 - ver? [95108-20PC84] - Project Manager

File Document “iew Project  Synthesiz  [mplementation Tool: Help

Dle| 8] oln|aw|nlgl nl Bz x

File= * “erzionz Flowy . Cortentz  Reports
B [THver! (HC4000XL-40055LPC a4 =l
i ward . . |
ﬁﬂﬁveﬂ ffunctional structure) ti Name of active version

# ver!-Optimized (optimized

B revt {Implemented, QK @ i]i_

- wer2 (XC9500-95108PC84-20
= ( ) DESIGM ENTRY
"r‘é}éverz ffunctional structure) .

w ver2-Optimized (optimized
>3 » B

SYNTHESIS SIMULATION
2P s B » = 0
IMPLEMENTATION ¥ YERIFICATIOMN
BV i*
= b s
PROGRAMMING
| : -
Dpm : Done E

Fecm o Implementation ver2 Completed Successfully.

Fecim - Deleting files fram cprag21idsgnt _1dpm_net

Dpm : Export werZ-Optimized to ciprag21idsant _1dpm_net ...
Fecm  Reading Synopsysikiling project

Conzale  HDL Errors  HDL Warnings © HDL Messages 14 ﬂ

Ready




As compared to the XS40 Board, the CPLD on the XS95 Board has different pins
connected to the parallel port and LED digit. Therefore, we need to change the pin
assignment constraints in the dsgn1_1.ucf file. Click on the Files tab in the Project
Hierarchy pane and then double-click the dsgn1_1.ucf file name to edit the user
constraints file.

‘»dzgnl_1 - ver? [95108-20PC384] - Project Manager _ O] x|

File Document Yiew Project  Synthesziz  Implementation Tools Help

] [=1 a1 Y BN R e I ST [

Files \ Wersions \ Flany \ Contents \ Reports \
B3 dsgnl_1 =
- M ver? B
& Sy ledded.vhd
-~ B dsgni 1
EJ simptims @ ili—
o 3 %3500 DEsiGM EnTRY 3
A4
Zl» 3 3 F
SYNTHESIS SIMULATION
#
a4
2o » » B
IMPLEMENTATION ¥ YERIFICATION
2
PROGRAMMING =
Fecm o Implementation ver? Completed Successiully. E

Fecm o Deleting files from ciprag21idsognd _1wdpm_nett

Dpm : Exportver-Optimized to ciprag21idsgnt _1wdpm_net ..
Fecm  Reading Synopsysixiling project

Pom o Execute: cifndtmactivelexeirhrowser. exe

Consale I..-" HOL Errors I..-" HOL wvarnings I..-" HOL Messages I.-"' || 4 | _>|
|Ready




Edit the pin assignments for the XS95 Board as follows. Then save the file and exit.

E! dsgnl_1.ucfk - Report Browser O] x|

File Edt Seach “iew Toolz Help

Dl=(@| 8| ¢ [=]2] v ] 4 2

net d<0> loc=p46;
net d<1> loc=p47?;
net d<2> loc=p48;
net d<3> loc=ph0;
net s<0> loc=p21; i
net s<1> loc=p23;
net 5<2>» loc=p19;
net s<3> loc=pl7;
net s<4> loc=p18;
net s<b> loc=pl4;
net s<6> loc=p15k;

[« | 2
Fleady [ nM,Col17 OvR ) [ [ 2

5 @ e

869 ' '

2104 XC95108 =g ¥~

S CPLD S3

50 S2 S1

¢ 2l -

S0 Y SO

© oY

T |5 Q

o O

<

Figure 3: Connection of the parallel port and LED digit to the pins of the CPLD on
the XS95 Board.



Now start the implementation tools that will map the netlist to the XC95108 CPLD.

‘»dzgnl_1 - ver? [95108-20PC384] - Project Manager

File Document Yiew Project  Synthesziz  Implementation  Tools

=10] %]

Help

] [=1 a1 Y BN R e I ST [

Filez \ Wersions \
B3 dsgnt_1
dzgnt_1.uc
E- Gy ledded vhd
- B dsgnt_1
B simprims
B %9500

=T o

A 4

Zo »

Flany \ Contents \ Reports \

&% 1B

DESIGN ENTRY
SYNTHESIS

IMPLEMENT

[

=

| 4

¥ SIMULARTION
.

» B

YERIFICATION

o-a
(=]
dron 7
Implermentation

SR |

PROGRAMMING

Perm
Dprm
Perm
Perm
Pcrm

Consale I..-" HOL Errors I..-" HOL wvarnings I..-" HOL Messages I.-"'

- Deleting files from clprag21idsognt _1wdpm_nett

: Export wer2-Optimized to clprag21idsognt _1dpm_net ..
- Reading Synopsysixiling project
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|Ready




The Synthesis/Implementation setting window will appear. Press the SET button so
we can tell the implementation tools where to find the updated user constraint file.

]|
Toplevel  |ledded ERIEEN
oK |

Wersion name; I'-.-'erE

Synthesis Settings: SET I LCarncel |

Help |
Target Device
Famiy: |-C3500 |
Device:lElE‘IElEF'l:B4 I 5peed:|-2|:| 'I

[T Edit Synthesis/mplementation canstraimts

I iew Estimated Performanee after D ptimization

¥ ‘&t Bun mplementation bools

Phwszical Implementation zettings

Revizion name: rev] Options |

Contral Files: SET

In the Settings window, the drop-down list for the Use Constraints file from: field contains a
few more entries than it did last time. The first two entries refer to constraint files for the
previous version targeted at the XC4005XL FPGA, so they are not suitable for this
version. Select the Custom entry.

Settings |

Implementation control files |

— Current Revizion Control File Settings:

Use Constraints file fronm: Mone j
Last Revizion(verl-xrevl]
Copy Guide file from: werl -rrev]

Copy Floorplan files from:

— Current Revizian Contral file uge:
[ Enable Guided MAP and PAR

[" Enable Floorplanning

k. I Cancel Help |




Click on the Browse button in the Custom window that appears.

Cusztom |

Constraints File: || Eruwte... |

Then move to the top level of the project where the modified user constraints file is
found.

Select file HE|

Lock jr: | {2 dsgnl_1 j ﬂl
@ Desktop

% jzmrﬁ 5 by Cormputer

=~ m:g =4 3% Floppy (&)

) g= [T
I:I =pro| ] Prag?1i
dzgn 3

g Removable Dizk (D]
(E:]
M etwark, Meighborbiood

Filz narme: |dsgn1_‘|.ucf Open I
Files of bype: ILlser Cansztraints [ LUCF) j Cancel |

Highlight the user constraints file and click on Open.

T T
Loak jr: |ﬁ dzgnl_1 j ﬁl

E dprn_net
= dzagni_1
b

I WProj

@ dzgnl_1.uck

File marme: |dsgn1_‘| uck Open

Files of ype: ILlser Constraints [*IJCF] j Cancel |




The Custom window now reflects the name of the user constraints file. Click on OK.

Cusztom |

Conztraints File: |dsgn1_‘|.ucf Browse... I

1] {\@J LCancel | Help I

Then click on OK in the Settings window.

Settings |

Implementation control files |

— Current Fevizion Control File 5 ettings:

|lze Canstraintz file from:

Copy Guide file from: I MHone

Led Lol

Copy Floorplan files from; INDnE

— Current Revizion Control file use:
[ Enable Guided MAP and PAF

[ Enable Flaarplanring

k. Cancel Help |




Now that the user constraints file for the XS95 Board has been specified, click on Run to
start the implementation tools.

Synthesiz/Implementation zettings

Toplevel  |ledded -] Bw
Wersion name: I'-.-'erE (] |
Synthesis Settings: SET I LCarncel |

Help |
Target Device
Famiy: |-C3500 |
Device:lElE‘IElEF'l:B4 I 5peed:|-2|:| 'I

[T Edit Synthesis/mplementation canstraimts

I iew Estimated Performanee after D ptimization

¥ ‘&t Bun mplementation bools

Phwszical Implementation zettings

Revizion name: Irev'l Options |

Contral Files:




The Flow Engine window appears, but only four steps are required for a CPLD
implementation versus the five steps used in an FPGA implementation. (The Fit step
does the same things for a CPLD that the Map and Place&Route steps do for an FPGA.)

ﬂdsgm_] [v¥er2->re¥1] - Flow Engine

Flow “iew Setup Utiities Help
Bl &R oM

XC9500 Design Flow [rev1]

S

ooo
¥z

Status: OK

Translate Fit Timing Bitstream
Completed | Running [ |
=
Checlking ezpanded de=sign . ..
HGDEUILD De=ign Results Summary:
Humber of errors: I}
Humber of warnings: i}

Writing HGD file "d=gnl 1 .ngd"
Writing HGDEUILD log file "d=qnl 1 . bld4". ..
HGDEUILD done.

4| -
e iy e e

[XC95108-20-PCB4 [dsanl_1.ucf |

For Help, press F1

The implementation phase should complete without incident.

Project Manager

Flow Engine wer2-»rewl Completed Successiully.




Now that the implementation is completed (note the green checkmark in the
Implementation box), we can check the CPLD utilization and pin assignments with the
report browser.

‘»dzgnl_1 - ver? [95108-20PC384] - Project Manager _ O] x|

File Document Yiew Project  Synthesziz  Implementation Tools Help

D] 8] Oln| oz Ble B B3|

Files \ Wersions \ Flany \ Contents \ Reports \
B3 dsgnl_1 =

EI dsgnt_1.uc verd revl (C95108-20-PCE4) -

& Sy ledded.vhd

-~ B dsgni 1

EJ simptims @ ili—

o 3 %3500 DEsiGM EnTRY 3

A 4
1» 3@ [ 3 F
SYNTHESIS SIMULATION
#
A 4
B> » » B R
IMPLEMENTATION YERIFICATION
»
PROGRAMMING =

Hig Flowe Endine: ver2-=renv (Translated Qk) E
Hig . Flowe Enaine: wverZ-=reyl (Fitted O
Hig : Flowe Endine: werZ-=reyl (Timed Ok)
Hig : Flowe Endine: verZ-=rexvd (Implemented Ok
Hig . Flowe Endine werZ-=revl Completed Successiully,
Consale I..-" HOL Errors I..-" HOL wvarnings I..-" HOL Messages I.-"' |!4| | _>|

|Open5 the Xilink Repaort Browser

For CPLDs, the device utilization summary and the pin assignments are both recorded in
the Fitting Report. Double-click the icon to view this file.

+ Report Browszer - dsgnl_1[verZ2->revl] &

Tranzlation Pzt Layout
Report Timing Report

The summary of the CPLD resources that are used by the LED decoder is placed at the
top of the file. The circuit uses eleven I/O pins of the 69 present on the CPLD. Seven



macrocells are used to hold the combinational logic for the LED decoder’s outputs. As
with the FPGA, the LED decoder does not consume much of the CPLD resources.

File Edit “iew Inzert Format Help

i [=] B3

D) |E| S| s8] o |o|@] |

XACT: wersion C.22

Design Name: dsgnl 1
Fitting 23tatus: 3Juccessiul

Lo o ol ol ol ol o ol ol o o ol ol ol

Eesource Juwmmary

Xilinx Inc.

Fitter EREeport

Date: 1-15-2Z001, 10:10FHM

ool ol o o o ol ol o ol ol ol ol

Deszign Device Macrocells Froduct Terms Fins

Name T=ed T=zed T=zed T=ed

dagnl 1 ZCO5E105-20-PCE4d 7 /108 | &%) Z85 /540 | 4%) 11 /63 [ 15%)
PIN EE3OURCES:

Signal Type Fecgquired Mapped | Fin Type U=zed Femaining
____________________________________ |_______________________________________
Input 4 4 | IO 11 gz
Cutput 7 7 | GCE/ IO o 3
Bidirectional u] u} | GT3/I0 u] z

GCE u} o | GSR/ IO u} 1

GTS o u} |

G3R u] u} |

Trtal

For Help. press F1

11

11

=
Tz




The pin assignments are found further down in the file. As expected, the implementation
tools assigned the inputs and outputs to the same pins that we specified in the user
constraints file.

B dsognl_1.1pt - WordPad _ O] x|
File Edit %iew Insert Fomat Help

D= Sl s o=@ B

FEXEXXXRRXXITTETResources Used by Successfully Mapped Logili d
Pin number column
% LOGIC **% J
Signal Total SGignals Loc Fur Slew Pin in Pin
Iame Fr Used Hode Rate # Type Use
=0 4 4 FE3 11 &TD FAST 21 /0 o
=R el 3 4 FB3_12 3TD FAST 23 I/0 o
s> 3 4 FE3 B8 3T FART 19 /0 o
I3 3 4 FB3_5 3TDh FAST 17 I/0 o
w4 4 4 FE3 6 3T FART 15 /0 o
S5 4 4 FB3_2Z 3TDh FALST 14 I/0 0
b 4 4 FE3 3 3T FART 15 /0 o
% INPUTS ++
Signal Lo Pin Pin Pin
Naane # Type Use
d0x FBe_3 416 I/0 I
d<1x> FE& 5 47 /0 I
d<2x FE&_6 45 I/0 I
d<3> FE& 8 =] /0 I
End of FEesources Used hy 3uccessfully Mapped Logic
=l

For Help. press F1 p




We need to do a little more processing on the bitstream output by the implementation
tools before we can download them to an XC9500 CPLD. Click on the Programming box
in the Design Flow pane to begin this step.

‘»dzgnl_1 - ver? [95108-20PC384] - Project Manager _ O] x|
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|Ready




The JTAG Programmer window will appear displaying a single XC95108 device.

dsgnl_1 - JTAG Programmer Mi=] E3
Eile Edit Operations Output View Help
D|=|E| s[m|e]o| | =25 2[5 HE S| 2w
s ﬂ XA C.T
5 T E " P
H:95108
dsgnt_1.jed JTAG Programmer
TDO Releaze Version: 2.1i_spb
Application Version: C.22
Serial Mumnber: 5131001576330
Copyright [c) 1995-1334 Kiling, Inc.
Al rights resersed. %
For Help, press F1 [T 2

We need to translate the bitstream into the SVF format that is compatible with the
GXSLOAD utility. Select Output->Create SVF File... to store the translated bitstream into a

file.

dsgnl_1 - JTAG Programmer
File Edit Operations | Qutput Wiew Help

=10) x|

2ss] SHE| S 2w

0 = E clﬁls B Cable Auto Connect

| | | I Cable Setup...
Cable Beset

v s Cable...
Create 5WF Fils...
&ppend to 5%F File...
TOI ]
Hiza5108
dsgnl_1 jed
TOO

|

Creates an S¥F file and directs subsequent operations to it

[T

|+

[ 4




In the SVF Options window, select the Through Test-Logic-Reset radio button. This will
insure that the downloading circuitry of the XC9500 CPLD is properly initialized before
the bitstream enters the device. Then click on OK.

SVF Options ]|

[nitial tranzition ta Bun-T ezt dle:

" Through T est-Logic-Feset

" Skipping Test-Logic-Reset

k. I‘_“ I Cancel Help

The Create a New SVF File window will appear next. By default, the SVF file will be
stored in the folder for this verison and revision of the project in a file called dsgn1_1.svf.
Just click on Save to accept these defaults.

Croae o NowSVE Fle G
Savejn:la ren] j El

Save 53 type: | SVF Files(*.svi] -] Cancel

File name: Idsgn‘l_'l Javf Save RI




Once the SVF file specified, it is time to generate the translated bitstream. Since the
bitstream is going to be programmed into the CPLD, select the Operations—=> Program item
from the menu list.

dsgnl_1 - JTAG Programmer M =]

File | Edit | Operations Output Miew Help

||| EETIR s | | 3] 2]

Eraze
Functional Test
Blank Check
Beadback Jedes
Get Device [D
Ol - et Device Checkaum
et Device Signature/lzercode

|+

Chain Operations...

d=gnl_1.jed

TDO

=
1 | 5

Programs the selected devices in the JTAG chain SVF Mode | | -




The Options window will appear with a set of actions we can add to the programming
bitstream. The Erase Before Programming option should be checked to force the CPLD to
erase its internal Flash storage before the new bitstream is loaded. (Failure to erase the
storage can lead to errors if the CPLD was previously programmed with a different
bitstream.) None of the other options are applicable to this example so they should be
left unchecked. (Definitely do not check the Write Protect box or you will be unable to
load new bitstreams into the CPLD in the future.) Click on OK after setting the options as
shown below.

Options |

Frogram Ophions |

W Erase Before Programming [~ <1 ey 2imy

[T Werify [ ‘wiite Protect
[ Functional Test [T Eead Protect
[T Rarallel Mod I” Load Fpoa

™ Esternal BinWerfication  FPin #: I
[T Usercode (& Hes Chars) I FFFFFFFF

k. fi I Cancel Help

An Operation Status window appears to show you the progress as the SVF file is
generated. Click on OK after all operations are complete.

Operation Status |

Loading Boundamy-Scan Description Language [BS0OL] file |
T Fndtind=c9500/datafwc 95108, bed'. .. .completed successfully,

'dzgnl_T1[Devicel ] Generating S%F vectars ta check boundary-zcan chain
inteqrity. .. done.

'degnl_1[Devicel]: Generating SYF wectors to put device in ISP mode...done.
‘dzgnl_T1[Devicel]: Generating S%F vectars to eraze device....done.

‘dzgnl_T1[Devicel ] Proceszing JEDEL file...done.

'degnl_1[Devicel]: Generating SYF vectors to program device....done.

‘dzgnl_T1[Devicel | SYF wvectar generation for programming completed succeszfully.

I

All operationz were completed succeszstully,

View Log File |




Now that the SVF file with the translated bitstream has been created, we can exit the
JTAG Programmer window.

dsgnl_1 - JTAG Programmer M=l E3
| File | Edit Operations Output  Wiew Help

e [Ctrl+ ww|oo B ? HH

Doen. oo L] sl D) & 2w

Initialize Chain Chrl+! [~

Webug Chan... [Ctrl+B

Save Chil+5

Save Az

1 E:hwbpekexhuinfehuinf, cdr
2 il ERLES, . Suinfe, cdf
2 Chwbpckextier2tadder. cdf

A Chwbpckeshes] edded, edf

Mew Log File. ..

Ereferences... |
| A | _I_I
Quits the application SVF Mode | |

Upon exiting the JTAG Programmer window, you will be asked if you want to save any
changes. This is rarely necessary so click on No. (This will not affect the SVF file that
was already created.)

JTAG Programmer |

& Save changes ta dzgnl_17
Mo QJ Cancel |




Now we have to go find the SVF file with the bitstream. It will be stored in the folder for
reversion rev1 of version ver2 of the dsgn1_1 project as shown below.

=10] x|

J File Edit “ew Go Favortez Help |

|« -=» BRI XE

Jﬁddress 1 C:MPragativdsgnl_1ssprojiverve j

cornmard. bis dzgrl_T.rpt resvizion. rbf
dsanl_1.bld [T dzan_1. = E]

deanl_1.ct deanl_1.tim #9500, imp
dzanl_1.data dzanl_1.ucf w3500, zml

= revl

b=
B-no| "
Tl el

dzgnl_1.gpd
dsgrl_1.jed

dzgnl_1.vmbE
dzgnl_1.=bt

dzgnl_1.log fe.log
dzanl_1.mod jtagparnr. log
dzanl_1.nga program. his
dzanl_1.nod revvizion, obf

|1 object[z] selected

|BEEKB | My Computer

4

With the XS95 Board connected to a power supply and the PC parallel port, just drag-
and-drop the dsgn1_1.svf file over to the gxsload window.

= revl

J File Edit “iew Go Favaortes Help

| -= - ¥ B3 0 XE|E

J Address I[:I C:APrag2ivdsgnl_1\sprojwer2ies

=101 ]

Drop .BIT. .SWF, HEx, and .ExO
filez here to download to the
®5 or X5V Board.

Recent Files:

[ EEPROM

Beload |

Part Im

comrand. his
dsgnl_1.bld
dsgnl_1.ctl
dsgnl_1.data
dzgni_1.gud
degnl_T.jed
dzgnl_1.log
dsgnl_1.mod
dzgnl_1.nga
dzgnl_1.ngd

dzgnl_T.rpt
. = Y
ds tirn
dsgnl_1.uck
dzgnl_1.wmb
dagrl_1.=bt
fe.log
jtagpgrmr.log
program. his

revigion. obf

revizion. b

#cI500 imp
%9500, 5ml
rptbnwsr. dat

|1 object(z] selected

| My Computer

v




It will take a minute or so for the bitstream to download into the XC95108 CPLD on the
XS95 Board. (Most of this time is used to erase the nonvolatile Flash memory in the
CPLD that stores the bitstream.)

Drap BIT, 5WF, HEX, and EXD

Il
filez here to download to the

E xit |
#5 ar #5Y Board.

iE] GXSLOAD x|
@ The #5935 Board is programmed!!

OF. |

Belzad [~ EEFROM Fort |LPT1 =

Once the XS95 Board is programmed, we can test it in exactly the same way we tested
the LED decoder circuit with the XS40 Board. The results should be the identical.

X gxsport M=l E3
of o 1] 1] o] o] of of _em|
DY De D5 D4 D3 D2 D1 DO
Stobel] | Count F'-:urtILF'T1 vI
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